Basic Site To Site VPN










This is how you can setup an encrypted site-to-site VPN connection. This is good for when you need a secure way to transfer data over the internet or some other insecure medium fairly permanently.
We do this by deciding what traffic will be using the VPN.
Next we’ll be enabling and defining ISAKMP policies; these are what define how your VPN works: do you want to use DES or AES and what bit. These policies must match 100% if there are any differences they won’t be used.
Next we’ll be defining the pre-shared key and the IP of the other end of the VPN. The router will use an MD5 or SHA1 hash of this for authentication.
Then we’ll create a transform-set, which is an acceptable combination of security protocols and algorithms.
Set the other end of the VPN and reference the traffic that is going over the VPN.
Select the asymmetric VPN protocol you want to use: such as Diffie Hellman or RSA.
Select the transform-set we defined before.
And finally select which interface the VPN will be running on.
The major concept to understand about the site-to-site VPNs is the key exchange/encryption. Both routers have a public and private key. The public key is used to decrypt the traffic from the private key and private key is used to decrypt the public key. The part I could never get was that though the awesome power of math you can’t decrypt the traffic from the public key if you have both the traffic and the key, only the private key can decrypt the the public key. The public keys are then transferred between the 2 routers and both use the other one’s public key to encrypt everything. The reason why it doesn’t stop there is cause asymmetric key encryption is VERY resource intensive (more than 100x more intensive than symmetric encryption). So the routers use this uber-encryption to send over keys for symmetric encryption. By default a new symmetric key is generated every ~4mb of traffic or 1 day (which ever comes 1st).

R1 Config w/ Inline Notes

!This defines an ACL that says what traffic will being going over the VPN
ip access-list extended VPN
permit ip host 10.0.0.1 host 10.0.0.2
permit icmp host 10.0.0.1 host 10.0.0.2

!Enables ISAKMP
crypto isakmp enable

!This is per connection: you can have lots of VPNs coming to 1 router, each one has a policy number
crypto isakmp policy 100

!Sets up what symmetric encryption key to use: in this case AES 128 bit
encryption aes 128

!Set this to use pre-shared key for verification such as; 
making sure George is George instead of bad-guy pretending to be George
authentication pre-share

!Sets it up to use the Diffie Hellman 1024-bit encryption for the asymmetric encryption
group 2

!Use the SHA hash file type which is MD5's new replacement
hash sha

!Make a new key in 86400 sec (24 hours)
lifetime 86400

!Sets the pre-shared key (MONKEY) that the other router (10.0.0.2) should have
crypto isakmp key MONKEY address 10.0.0.2

!Define an acceptable combination of security protocols and algorithms 
(defined as DLOTS in this case) this is called transform-set
crypto ipsec transform-set DLOTS esp-aes 128 esp-sha-hmac

!Sets the following that will be referenced in an interface
crypto map MAP 100 ipsec-isakmp

!References the VPN ACL noted earlier
match address VPN
!Sets the other end of the VPN
set peer 10.0.0.2

!Specifies that IPSec should use the 1024-bit Diffie-Hellman
set pfs group2

!References the "crypto ipsec transform-set DLOTS esp-aes 128 esp-sha-hmac" line above
set transform-set DLOTS 

!Says what port to associated  with the "crypto map MAP 100 ipsec-isakmp" line above
int fa0/0
crypto map MAP
ip address 10.0.0.1 255.255.255.0

R2 Config

ip access-list extended VPN
permit ip host 10.0.0.2 host 10.0.0.1
permit icmp host 10.0.0.2 host 10.0.0.1

crypto isakmp enable
crypto isakmp policy 100
encryption aes 128
authentication pre-share
group 2
hash sha
lifetime 86400

crypto isakmp key MONKEY address 10.0.0.1

crypto ipsec transform-set DLOTS esp-aes 128 esp-sha-hmac

crypto map MAP 100 ipsec-isakmp
match address VPN
set peer 10.0.0.1
set pfs group2
set transform-set DLOTS

int fa0/0
ip address 10.0.0.2 255.255.255.0
crypto map MAP

0 comments:

About US

Network Bulls is Best Institute for Cisco CCNA, CCNA Security, CCNA Voice, CCNP, CCNP Security, CCNP Voice, CCIP, CCIE RS, CCIE Security Version 4 and CCIE Voice Certification courses in India. Network Bulls is a complete Cisco Certification Training and Course Coaching Institute in Gurgaon/Delhi NCR region in India. Network Bulls has Biggest Cisco Training labs in India. Network Bulls offers all Cisco courses on Real Cisco Devices. Network Bulls has Biggest Team of CCIE Trainers in North India, with more than 90% of passing rate in First Attempt for CCIE Security Version 4 candidates.
  • Biggest Cisco Training Labs in India
  • More than 90% Passing Rate in First Attempt
  • CCIE Certified Trainers for All courses
  • 24x7 Lab Facility
  • 100% Job Guaranteed Courses
  • Awarded as Best Network Security Institute in 2011 by Times
  • Only Institute in India, to provide CCIE Security Version 4.0 Training
  • CCIE Security Version 4 Training available
  • Latest equipments available for CCIE Security Version 4

Network Bulls Institute Gurgaon

Network Bulls Institute in Gurgaon is one of the best Cisco Certifications Training Centers in India. Network Bulls has Biggest Networking Training and Networking courses labs in North India. Network Bulls is offering Cisco Training courses on real Cisco Routers and Switches. Labs of Network Bulls Institute are 24x7 Available. There are many coaching Centers in Delhi, Gurgaon, Chandigarh, Jaipur, Surat, Mumbai, Bangalore, Hyderabad and Chennai, who are offering Cisco courses, but very few institutes out of that big list are offering Cisco Networking Training on real Cisco devices, with Live Projects. Network Bulls is not just an institute. Network Bulls is a Networking and Network Security Training and consultancy company, which is offering Cisco certifications Training as well support too. NB is awarded in January 2012, by Times, as Best Network Security and Cisco Training Institute for the year 2011. Network Bulls is also offering Summer Training in Gurgaon and Delhi. Network Bulls has collaboration with IT companies, from which Network Bulls is offering Networking courses in Summer Training and Industrial Training of Btech BE BCA MCA students on real Live projects. Job Oriented Training and Industrial Training on Live projects is also offered by network bulls in Gurgaon and Delhi NCR region. Network Bulls is also providing Cisco Networking Trainings to Corporates of Delhi, Gurgaon, bangalore, Jaipur, Nigeria, Chandigarh, Mohali, Haryana, Punjab, Bhiwani, Ambala, Chennai, Hyderabad.
Cisco Certification Exams are also conducted by Network Bulls in its Gurgaon Branch.
Network Bulls don't provide any Cisco CCNA, CCNP simulations for practice. They Provide High End Trainings on Real topologies for high tech troubleshooting on real Networks. There is a list of Top and best Training Institutes in India, which are providing CCNA and CCNP courses, but NB has a different image from market. Many students has given me their feedbacks and reviews about Network bulls Institute, but there were no complaints about any fraud from this institute. Network Bulls is such a wonderful place to get trained from Industry expert Trainers, under guidance of CCIE Certified Engineers.

About Blog

This Blog Contains Links shared by sites: Cisco Guides, Dumps collection, Exam collection, Career Cert, Ketam Mehta, GodsComp.co.cc.

NB

NB
Cisco Networking Certifications Training

Cisco Training in Delhi

ccna training in gurgaon. ccnp course institute in gurgaon, ccie coaching and bootcamp training near gurgaon and delhi. best institute of ccna course in delhi gurgaon india. network bulls provides ccna,ccnp,ccsp,ccie course training in gurgaon, new delhi and india. ccsp training new delhi, ccie security bootcamp in delhi.

Testimonials : Network Bulls

My Name is Rohit Sharma and i Have done CCNA and CCNP Training in Gurgaon Center of Network Bulls and it was a great experience for me to study in Network Bulls.

Cisco Networking Certifications

Myself Komal Verma and i took CCSP Training from Network Bulls in Gurgaon. The day i joined Network Bulls, the day i get addicted with Networking Technologies and I thank Mr. Vikas Sheokand for this wonderful session of Networking. :)
I must say that Network Bulls is Best Institute of CCNA CCNP CCSP CCIE Course Training in Gurgaon, New Delhi and in India too.
Komal Verma

About a wonderfull CCIE Training Institute in Gurgaon

I am Kiran shah from New Delhi. I have recently completed my CCNA CCNP & CCIE Training in Gurgaon from Network Bulls and i recommend Network Bulls for Cisco Training in India.

Kiran Shah

Cisco Coaching and Learning Center

Disclaimer: This site does not store any files on its server. I only index and link to content provided by other sites. If you see any file on server that is against copy right you can inform me at (sidd12341 [at] gmail.com). I will delete that materials within two days. This Website is not official Website of any Institute like INE, Network Bulls, IP Expert. Thanks

CCIE Security Version 4

Cisco Finally updated CCIE Security Lab exam blueprint. WSA Ironport and ISE devices are added in CCIE Security Version 4 Lab Exam Syllabus Blueprint. In Updated CCIE Security Version 4 Syllabus blueprint, new technologies like Mobile Security, VoIP Security and IPV6 Security along with Network Security, are added. As in CCIE Security Version 3 blueprint, Cisco had focused on Network Security only, but now as per market demand, Cisco is looking forward to produce Internet gear Security Engineer, not only Network Security engineers.
In CCIE Security Version 4 Bluerpint, Lab Exam is going to be more interested than before. What is Difference in CCIE Security Version 3 and Version 4? Just go through the CCIE Security Version 4 Lab Equipment and Lab Exam Syllabus Blueprints and find out!